Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trivial Medtrak generating medical records locks terminal up
So when I was making a bunch of fake crewmembers, I included creating medical and security records for them.  Security records worked fine, but medical records had some issues on generation.  If I told the system to generate a new medical record, it'd do it, but it'd also lock the terminal up every time and force me to reboot the terminal to continue working.

Steps to reproduce:
1: Login to SecMate and generate a new record for a person, this part does not matter on what you put in as far as I'm aware.  I filled out 1-6, and generated 99 for each record.
2: Login to MedTrak and go into your generated record.  I filled out 6 here, but I don't think it's necessary
3: enter "99" to generate medical records
4: you will be prompted to put something in, I have no idea what it wants, i tried everything from the record's name to "1"
5: Watch the record generate, press "R" to redraw, note that nothing's happening, try to leave ("0"), note that nothing's happening
6: Reboot terminal and relogin, open record, continue updating or close record at your whim.
Should be fixed!

Forum Jump:

Users browsing this thread: 1 Guest(s)