Goonstation Forums

Full Version: Interruptions make reverse-engineered frames unusable
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When you're a mechanic and you reverse-engineer items, you get frames that you have to deploy with a soldering iron. When you solder a frame, it takes a couple of seconds, during which the action can be interrupted. That's fine, BUT: If a frame is interrupted while being deployed, it becomes unusable. Trying to solder it will result in "You secure the frame" or "You unsecure the frame". I don't think there's any way to make it the item it's supposed to be.

In summary:

1) Use a reverse-engineering blueprint to create an item frame.
2) Solder the frame.
3) While soldering, immediately move to interrupt the action.
4) Try to solder the frame again, you can't.

I did this on Cogmap1.
ahaha, that's the text you'd get from the old mechanics frames from when you had to assemble the frames by hand and use them in hand to deploy

that's super bizarre. did you try using it in hand after securing it?
Okay, I just tried that, and it worked! Kind of. When I used it in hand, there was a little window "Ready to deploy?"; I clicked Yes and it said "This item must be soldered to deploy" or something like that. Then I tried to solder it, and it deployed as usual. So, it IS possible to 'reset' those frames so they can be used.

This shouldn't really happen to begin with, though...right?
definitely shouldn't be happening in the first place! but at least we have a workaround now